Enabling precompiled SAPI 5 grammar fails with SPERR_UNSUPPORTED_FORMAT 0x80045003 (-2147201021)

Last reviewed: 7/8/2010

PRB Article ID: P071006

The information in this article applies to:

  • GrammarKit 3

Symptoms

Enabling a precompiled SAPI 5 grammar in SpeechKit fails with error code SPERR_UNSUPPORTED_FORMAT 0x80045003 (-2147201021).

Cause

Grammar binary was persisted incorrectly to a file in some cases.

Status

Fixed in GrammarKit build 3.0.6.0.

Component Formats Impacted

All component formats.